viernes, 27 de junio de 2008

Podrá existir el dominio .costarica o .medford

Podrá existir el dominio .costarica o .medford

La autoridad que regula los dominio de Internet permitirá nombre de países, personas, marcas y cualquier cosa

Ayer se flexibilizaron las normas de inscripción de dominios y se permitará que en el 2009 el mundo vaya más allá de los típicos .com o .org y demás 21 dominios posibles en este momento.

Con aprobación unánime de la Internet Corporation for Assigned Names and Numbers (Icann), que administra y asigna los dominios en Internet, y para que haya más direcciones a disposición del público, ahora se permitirán los dominios que la creatividad humana creen mientras no superen los 64 caracteres, informó hoy el diario español El País.

Así, podrá existir el dominio .costarica, .medford o .cualquiercosa. Las personas físicas podrán tener un dominio con su nombre mientras demuestren un plan de negocios y la capacidad de administrarlo.

También se podrán inscribir dominios de marcas mientras el solicitante demuestre ser su dueño.

La Icann también permitirá el uso de caracteres asiáticos y árabes.

Con este cambio también la Icann aumentará sus ingresos, de los cuales el 95% viene de la inscripción de dominios, informó El País.


http://www.elfinancierocr.com/edactual/tecnologia1597654.html

jueves, 26 de junio de 2008

Dell ofrece notebooks con Red Hat Linux

El store de Dell para Estados Unidos ya está vendiendo por lo menos su portátil Precision M6300 (U$S 2184) con Red Hat Enterprise Linux WorkStation 5.1 de 64 bits incluído en su precio y con un año de subscripción al Red Hat Network (RHN), el servicio de Red Hat que ofrece soporte de parches, actualizaciones y correcciones para los paquetes de software instalados. Por otros U$S 299 se puede tener el mismo sistema operativo pero con 3 años de subscripción al RHN.

La Dell Precision M6300 de 17" wide incluye un CPU Core2Duo de 2.0 GHz, 1 Gb de RAM DDR2 667 MHz, disco de 80 Gb y 5400 RPM, video NVidia Quadro FX 1600M de 512 Mb, wifi 802.11 a/g Intel 3945 y un DVD-ROM 8x.


Fuente

Kumbia 0.5 RC1

Ya está disponible la primera Release Candidate de Kumbia 0.5, el framework escrito en PHP5 por colegas hispanoparlantes basado en las mejores prácticas de desarrollo web (plantillas, caché, scaffolding, MVC, Ajax, etc.). Kumbia 0.5 RC1 es liberado para que la comunidad pueda encontrar posibles bugs y testear las nuevas funcionalidades, entre ellas:

  • Nuevo adaptador MySQLi
  • Nuevo adaptador PDO para MySQL, PostgreSQL y SQLite
  • Reestructuración de ActiveRecord (más rápido, consistente y estable)
  • Soporte para multiples aplicaciones dentro de un mismo release de Kumbia
  • Nuevo sistema de configuración para soportar varias aplicaciones
  • Nueva presentacion de excepciones muestra más información
  • Soporte para desarrollar de manera modular, ej.: modulo/controller/action

Y como en este tipo de software la documentación es imprescindible, sus autores muy acertadamente continúan escribiendo el libro oficial de Kumbia y su primera parte ya está casi completa y disponible en su wiki.

Fuente

Ubuntu MID 8.04

Canonical anunció así el lanzamiento de su Ubuntu Mobile Internet Device (MID) Edition 8.04, adaptada a las pequeñas pantallas táctiles de MIDs (Mobile Internet Devices) y UMPCs (Ultra-Mobile PCs), basada en la iniciativa Moblin de Intel y la edición Desktop de su propia distribución.

Esta edición de Ubuntu es en realidad una vuelta de tuerca de Ubuntu Netbook Remix, otra edición específica para los nuevos ultraportátiles de bajo coste que también se benefician del proyecto Moblin y que, eso sí, no cuentan con una interfaz táctil.

Entre las aplicaciones integradas están un nuevo navegador específico para estos dispositivos llamado MID Browser y desarrollado sobre la base de Gecko (parece evidente que no es un Firefox 3) además de otras soluciones muy orientadas a aprovechar la conectividad de estos dispositivos, como una versión específica de Pidgin, el cliente de mensajería multiprotocolo para Linux. También hay algunos juegos y un reproductor multimedia llamado Moblin Media que permite reproducir todo tipo de formatos.

Fuente


miércoles, 25 de junio de 2008

Windows XP, soportado hasta el 2014

Microsoft ha confirmado que seguirá dando soporte a Windows XP hasta el 2014. La poca demanda que tiene Windows Vista en el mercado, y el hecho de que los clientes corporativos tampoco se actualicen a Vista, ha hecho que Microsoft tome esta decisión.

Fuente

Calcular Red, broadcast, mascara, etc con IPCAL

IPCAL es una herramienta para calcular Red, broadcast, mascara, etc desde una dirección ip.

Para instalar en debian, apt-get install ipcal.

Sitio Oficial

viernes, 20 de junio de 2008

El Desastre Debian nos afectará por años

La eliminación de tan solo dos líneas de código causó una grave crisis de seguridad


Pasará mucho tiempo antes de que estos días se olviden en la comunidad del software libre. Y nadie sabe hasta dónde llegarán las consecuencias de lo que ya se conoce como el Desastre Debian . "¿Pero sabés que es lo mejor –me decía en estos días un hacker amigo–, que aunque estamos profundamente avergonzados, dolidos y enojados, de todas maneras lo hicimos público, no lo ocultamos. Y sabemos que vamos a salir adelante."

Para resumir el incidente, los sistemas que usan la distribución de Linux llamada Debian estuvieron un año y ocho meses creando contraseñas públicas totalmente inseguras. Y esto ocurrió porque dos líneas de código fueron eliminadas de una aplicación conocida como OpenSSL . El Desastre Debian no afecta solo a Linux, sino que alcanza a cualquier sistema que tenga alguna relación con la seguridad en Internet.

El asunto es interesante porque quedó demostrado que sólo dos líneas de código realmente pueden causar una catástrofe de seguridad, y porque se trata de una cuestión técnicamente muy compleja que nos afecta de forma directa y cotidiana. La mayor parte de los tecnicismos quedarán fuera de esta columna, para no volverla indigesta, pero los curiosos podrán leer más detalles en los links que aparecen a lo largo del texto.

Contraseñas públicas

Cada vez que hacemos transacciones bancarias o comerciales en Internet, los datos son encriptados durante el trayecto, de tal manera que un pirata informático no pueda espiar nuestras contraseñas y otros datos sensibles. Encriptar algo es, en pocas palabras, convertirlo en un galimatías inextricable que sólo puede descifrarse si se cuenta con las contraseñas adecuadas.

En las comunicaciones por Internet se usan SSL o TLS . Las siglas vienen de Secure Sockets Layer y Transport Layer Security . En el proceso se requieren contraseñas públicas que cada parte produce aleatoriamente. Funciona bien, o razonablemente bien, considerando la inseguridad inherente a la Red.

El único pequeño problema es que, al revés que en el mundo real, en las computadoras el azar sencillamente no existe. Se lo puede emular con bastante fidelidad, pero es uno de los puntos débiles de estas tecnologías. El azar, en el mundo informático, puede volverse algo más o menos predecible; y aun el mejor de los azares no es azar verdadero. Estos números supuestamente aleatorios creados por las computadoras se llaman, por esto, seudoaleatorios .

Para crear las claves que intercambian nuestra PC y el servidor con el que queremos conectarnos (el del banco, digamos) se debe producir números al azar; seudoaleatorios, en rigor. Se usan para esto semillas , es decir, otros números, también al azar y en un rango muy grande. ¿Por qué es tan importante la semilla ? Porque es casi la única forma de evitar que el número pseudoaleatorio con el que se crean las claves públicas se vuelva predecible. De ocurrir esto, el cifrado se desmoronaría.

OpenSSL es una implementación de código fuente abierto de SSL y TLS . Su versión inicial salió en mayo de 1999 y fue la primera aplicación de software libre validada por la autoridad de tecnologías de encriptación de Estados Unidos. Nada hacía suponer que uno de los más prestigiosos paquetes de software libre estaría en el centro de una tormenta global nueve años después. Y mucho menos que involucraría a la más respetada de las distribuciones de Linux, Debian.

Caos de juguete

Al revés que Windows o Mac OS, Linux no tiene una única versión, sino que llega al público y las empresas bajo la forma de distribuciones, o distros , en la jerga. De hecho, cualquier persona con un poco de conocimiento y bastante paciencia puede armar su propia distribución ( www.gentoo.org ).

Las distros más conspicuas tienen un plantel estable de programadores, que adaptan el código fuente de Linux a fines específicos. Red Hat, por ejemplo, es una corporación que cotiza en Bolsa y cuenta con unos 2000 empleados. Canonical Limited, que compagina Ubuntu, tiene 130.

Debian es una rareza magnífica. Fundada por el alemán-norteamericano Ian Murdock, en 1994, el proyecto proponía algo que los cínicos de moda habrían encontrado risible: crear y mantener una distribución de Linux de forma cooperativa y abierta, con el mismo espíritu del software libre y con idéntica coherencia política; es decir, sin software de código cerrado de ninguna clase. La palabra Debian es la combinación del nombre de la novia de Murdock en la época en que inició el proyecto, Debra, hoy su ex esposa, y su propio nombre de pila. Ian lideró Debian hasta 1996, y actualmente es uno de los vicepresidentes de Sun Microsystems. Aquí, su blog, aunque no ha sido actualizado en los últimos dos meses: http://ianmurdock.com

Pese al supuesto exceso de idealismo (¿qué hubiera sido de nuestra especie sin los excesivamente idealistas?, me pregunto), Debian no sólo prosperó, sino que se convirtió en una de las distribuciones más populares y, por mucho, la más respetada. Que en estos días haya quedado asociada a un desastre de seguridad informática es a la vez una pena, una paradoja y en gran medida una injusticia, como se verá enseguida.

Pero constituye también una lección que el software libre deberá aprender, o arriesgarse a quedar convertido en una orquídea de invernadero o en instrumento de grandes corporaciones, como IBM o Google, habiendo así perdido por completo su sentido. Y hablo, como mínimo, de una simple ecuación económica; si el software libre desaparece, todos perdemos, incluso aquellos que no creen en él. Un estudio de la Universidad del Rey Juan Carlos, de Madrid, España, concluyó hace poco que si las 283 millones de líneas de código de Debian fueran propiedad de una compañía privada costarían unos 5400 millones de euros ( https://penta.debconf.org/~joerg/attachments/33-measuring_etch_slides.pdf ).

Pero, ¿qué pasó exactamente?

El 13 de mayo último, el proyecto Debian anunció que había descubierto una vulnerabilidad en el generador de números seudoaleatorios de su versión de OpenSSL . Dicho simple, su azar era previsible. ¿Por qué? Porque habían sido eliminadas dos líneas de código. A causa de esto, de manera silenciosa e invisible, se empezaron a usar como semillas los identificadores de proceso , los números que se asignan a cada programa que corre en un sistema, en este caso Linux ( www.debian.org/security/2008/dsa-1571 ). Puesto que en Linux sólo puede haber 32.768 identificadores de proceso, el número de semillas disponibles para generar números al azar se volvió ridículamente bajo. Como el algoritmo (la matemática) que se usa para producir números al azar es conocida, teniendo eso y las posibles semillas, es fácil adivinar el cifrado resultante.

Parecía tan sólo otro de esos miles de agujeros de seguridad que infestan el código de todas las aplicaciones informáticas de hoy. Pero era muchísimo más grave.

Durante un año y ocho meses, desde el 17/9/2006 hasta el 13/5/2008, cuando se corrigió la falla, los servidores basados en Debian habían estado produciendo claves fáciles de adivinar, predecibles y, por lo tanto, inútiles. Así que no bastaba con instalar la nueva versión corregida del paquete OpenSSL de Debian; había que regenerar los certificados digitales basados en esas claves públicas y volverlos a enviar a la autoridad competente.

Esas claves son independientes del sistema, por lo que la vulnerabilidad puede estar ahora enquistada en casi cualquier computadora del mundo. Oculta, olvidada, con una grave vulnerabilidad latente.

Y para empeorar todavía más las cosas, hay una cantidad de programas que se sirven de las bibliotecas de OpenSSL para hacer su trabajo de encriptación y seguridad.

Fue tan grave que el Centro de Tormentas de Internet ( www.sans.org ) no sólo lo reportó inmediatamente ( http://isc.sans.org/diary.html?date=2008-05-13 ), sino que subió su nivel de alerta a amarillo.

Sólo un par de días después de saberse la noticia, mis máquinas con Ubuntu instalaron una nueva versión de OpenSSL , y como parte del proceso me informaron que iban a recrear mis claves públicas; el sistema me avisó que, si no tenía idea de lo que esto significaba, le diera OK y me olvidara del asunto. Era una esquirla insignificante de un terremoto asolador. Me erizó la piel.

Quienes no leen inglés tienen un excelente resumen en español sobre el incidente en www.hispasec.com/unaaldia/3492

¿Qué toqué?

Aparte de la gravísima incertidumbre causada por casi dos años de crear y distribuir claves inseguras, está la humillación de cómo ocurrió la falla. Si no está sentado, hágalo ahora, porque la raíz del problema no puede ser más pueril.

Allá por 2006, un programador de Debian estaba trabajando en OpenSSL cuando el depurador, un sistema que se usa para detectar errores en el código, le hizo algunas advertencias sobre memoria no inicializada. Después de consultar con el grupo OpenSSL , simplemente decidió eliminar las líneas de código molestas, con las consecuencias antedichas. Dicha discusión puede verse aquí: http://rt.openssl.org/Ticket/Display.html?id=521&user=guest&pass=guest Según Debian, la intención de su programador era depurar el código, algo intrínsecamente bueno, y además hizo lo que correspondía, consultar con OpenSSL , que no encontró objeciones en eliminar dichas instrucciones ( http://wiki.debian.org/SSLkeys#head-a8437fc14786b3d5b9678241c7201c8c863555e7 ).

Pero el borrado de esas dos líneas de código causó que el generador de números seudoaleatorios (PRGN, por sus siglas en inglés) simplemente quedara restringido a usar 32.768 posibles semillas. Y adiós.

Si usted usa Ubuntu, Kubuntu o cualquier otro derivado de Debian, actualice el sistema, si no lo hizo ya, para corregir este bochornoso error y regenerar las claves criptográficas.

Si es administrador de sistemas, casi sin ninguna duda tiene relación con la seguridad informática, por lo que sería muy aconsejable que revise todo su sistema de certificados y claves criptográficas. Cuanto antes, mejor.

Lecciones al día

¿Puede uno hacer todo bien y, sin embargo, equivocarse? Oh, sí. Los periodistas lo sabemos bien. Podemos quemarnos el cerebro consultando las fuentes y reflexionando sobre un asunto, buscando todos los ángulos posibles para no imponer tendencia alguna a nuestro texto y, sin embargo, publicar algo que no es enteramente cierto. Habríamos necesitado quizá dos años y medio para hacerlo enteramente cierto. Pero debemos cerrar esa nota en el día. ¿Por qué?

Porque, como a los programadores, nos desvelan ciertos principios. En nuestro caso es la necesidad de dar a conocer. Es el mandamiento no escrito de esta profesión. Primero que nada, antes que nada y por sobre todas las cosas que el flujo de la información no se detenga. A veces este principio nos obnubila.

A los programadores los obsesiona la pureza del código. Es decir, que no sea propenso a errores. Sobre todo en un caso como el de OpenSSL , cuyas bibliotecas son usadas por numerosos programas de terceros.

Sinceramente, creo que el desarrollador de Debian que borró esas dos líneas de código se dejó llevar por este mandamiento informático. No quería mensajes de error del depurador porque esos mensajes significaban que en el futuro otros programadores podrían tener inconvenientes con OpenSSL .

Creo que fue Voltaire quien escribió que lo perfecto es enemigo de lo bueno: “Le mieux est l´ennemi du bien”. Todas las profesiones tienen alguna clase de ideal que, por momentos, puede cegar a sus cultores. Los de afuera nunca comprenden lo que se siente. Los que no son programadores encontrarán disparatado que alguien simplemente borre unas instrucciones, creyendo que están allí de adorno. No fue así, no fue tan simple, y no se puede simplemente crucificar al programador.

En cambio, todos tenemos que aprender aquí una lección. Igual que los periodistas seguiremos, inexorablemente, intentando que las cosas se sepan, incluso cuando podemos equivocarnos, los programadores no cejarán en el intento de depurar el código. Es inevitable.

La lección es otra. Todo código relacionado con la seguridad debería resolverse por medios más formales y estrictos que una lista de correo. Debian dice que la raíz del error estuvo en que “el programador consultó en la lista equivocada del grupo OpenSSL”.

Las listas de correo están muy bien, son una tradición, funcionan cuando todo lo demás falla, etcétera. Pero todo programador debería aprender que de ahora en más no puede eliminar ni una línea de código de un software de seguridad sin el visto bueno de una autoridad competente. O dicho de otro modo, que la seguridad está por encima de la pureza del código.

La segunda lección tiene que ver con la perspectiva. Creer que dos líneas de código son pocas, o que son insignificantes es miopía pura. Hoy se cree que el Titanic se hundió por culpa de sus remaches, que eran de mala calidad.

No ya dos líneas de código, sino un simple signo puede cambiar diametralmente una trayectoria, un vector, una cuenta. No es lo mismo haber llegado a tu primer millón de dólares (1.000.000) que haber llegado a deber tu primer millón (-1.000.000).

Se ha dicho que Dios está en los detalles.

Es la verdad.

Por Ariel Torres


http://www.lanacion.com.ar/tecnologia/nota.asp?nota_id=1017063

viernes, 13 de junio de 2008

Fin del soporte para FreeBSD 5.5, 6.1 y 6.2

Las versions de FreeBSD 5.5, 6.1 y 6.2 han "expirado" el pasado 1ª de Junio, y por lo tanto se aconseja a sus usuarios actualizarse a las más recientes versiones 6.3 y 7.0. Así lo dice una reciente actualización de las versiones soportadas por el FreeBSD Security Officer, con la que también concluye definitivamente el soporte de la rama FreeBSD 5-STABLE. Con respecto a las actuales versiones de las ramas 6.x y 7.x, se espera que, tentativamente, FreeBSD 6.3 alcance el fin de su vida útil para el 31 de Enero del 2010, y FreeBSD 7.0 lo haga el 28 de Febrero del 2009.

http://www.vivabsd.com.ar/distros/freebsd-5.5-6.1-y-6.2-fin-del-soporte.html

martes, 10 de junio de 2008

Backports

Para aquellos que utilizamos Debian o alguno de sus derivados (como Ubuntu) seguramente estará súper acostumbrados a la forma de instalar cosas. Para aquellos que no lo sepan, el sistema funciona con archivos .deb (llamados paquetes) instalados, configurados y demás mediante aplicaciones como dpkg, dselect, etc. El problema surge cuando un paquete necesita de otros paquetes para poder ser instalado.

Dependencias

Cada paquete tiene incluído, entre muchas otras cosas, una lista con los paquetes que necesita para poder funcionar; y no se dejará instalar a menos que todas ellas estén ya instaladas. Los quebraderos de cabeza que dieron estos problemas llevaron al desarrollo de apt-get, una aplicación que se encarga de resolver todas esas dependencias e instalar todos los paquetes necesarios en el orden adecuado para disminuir las molestias al mínimo. La diferencia es que el trabajo realizado necesita de todo un conjunto de paquetes disponibles (o al menos que se sepa de dónde obtenerlos) para poder decidir si puede resolver las dependencias de un paquete dado. De allí nace el concepto de “repositorio“: un conjunto de aquellos paquetes que pueden ser instalados en un sistema.

Pero eso no era suficiente. Además se desarrollaron aptitude y synaptic; dos interfases para apt. La primera corre sobre una consola gracias a las librerías de menúes ncurses; synaptic, por su parte, es la versión para entornos gráficos. Esto sería el ápice del manejo de aplicaciones en distribuciones de linux basadas en Debian por la simple razón de que es muy sencillo de utilizar para cualquier usuario… siempre que se tengan disponibles los repositorios adecuados. Cada repositorio tiene su propio conjunto de programas ¿y qué pasa si no está el que nosotros queremos?

En dichos casos se pueden hacer 2 cosas: compilarlo y correrlo u obtenerlo de algún otro repositorio e instalarlo a mano (tip: si se utiliza dpkg no se rompe la base de datos de aptitude/synaptic, si se utiliza apt-get sí). En ambos casos es algo tedioso y que requiere de ciertos conocimientos especiales. Para la primera basta con conseguir el código fuente, rezar y compilar. Para lo segundo, se dispone de apt-get.org, un sitio dedicado a la localización de los paquetes en el que basta con poner el nombre de la aplicación para obtener el repositorio necesario.

SIn embargo, no todos los repositorios tienen todas las versiones que nosotros necesitamos; y no todos para nuestra versión del sistema operativo o repositorios. Para cubrir esta necesidad, se engendró Backports.org: un proyecto para crear un repositorio no oficial con versiones no disponibles en los repositorios oficiales. He aquí una de las formas de tener los backports siempre disponibles sin romper todo el sistema.

Notas de Traducción

  • Este artículo fue traducido haciendo ejercicio de los derechos de uso brindados por la licencia del artículo original
  • El artículo original, al igual que su traducción, están bajo los términos de la Licencia para Documentación Libre de GNU (GNU Free Documentation License)
  • El artículo original como thread en un foro: Backports; latest and greatest for Sarge


La Traducción

Este artículo describe cómo instalar paquetes de backports.org. El método descripto en esta guía es sólo uno de muchas formas que se pueden utilizar y no pretender ser la mejor ni la más efectiva para utilizar backports. Si bien el método descripto debería de ser seguro, siempre es una buena idea hacer una copia de respaldo de información importante antes de hacer un cambio significativo al sistema. Esta guía está licenciada bajo los términos de la GFDL (GNU Free Documentation License). Fue escrito con la esperanza de que será útil a la comunidad pero no provee garantía alguna; usar bajo su propio riesgo.

Mucha gente siente que Debian Sarge se está añejando y optan, en su lugar, por instalar Testing o Inestable para obtener los últimos paquetes. La contra de esto es que tanto Testing como Inestable tienden a romperse. Backports.org es un repositorio que tiene muchos de los últimos paquetes compilados para Sarge de forma que uno pueda obtener los mejores y últimos paquetes sin necesidad de actualizar todo el sistema.

Preparando el sistema para Backports.org

Abrir, como super-usuario, el archivo /etc/apt/sources.list y agregar los repositorios de backports. Un archivo sources.list, para incluír backports incluídos, debería incluír la siguiente línea:


#Backports
deb http://www.backports.org/debian/ sarge-backports main

Nos gustaría poder elegir qué paquetes queremos instalar/actualizar desde Backports. Para ello, utilizaremos el pinning de apt dándole una menor prioridad que los repositorios principales al de Backports. Esto se logra en el archivo /etc/apt/preferences agregando una entrada para Backports.

En caso de que no tengas tal archivo, no hay necesidad de entrar en pánico. Sólo crea uno, como súper-usuario, con tu editor de texto preferido. Una vez que éste archivo exista deberá incluir las siguientes líneas para lograr el efecto deseado (explicación de cómo funciona el pinning)


Package: *
Pin: release o=Debian,a=stable
Pin-Priority: 900

Package: *
Pin: release a=sarge-backports
Pin-Priority: 200

Package: *
Pin: release o=Debian
Pin-Priority: -10

Instalando paquetes desde Backports.org

Una vez editados dichos archivos lo primero que hay que hacer es actualizar la lista de paquetes:


aptitude update

para poder instalar paquetes desde backports se ejecuta la siguiente instrucción:


aptitude -t sarge-backports install aplicación


http://enespanol.com.ar/2006/06/22/aplicaciones-en-linux-backports/

lunes, 9 de junio de 2008

Debian GNU/Linux 5.0 Beta 2

La segunda versión preliminar Beta de lo que eventualmente se convertirá en la próxima versión 5.0 stable de Debian GNU/Linux, o más simplemente, "Lenny", ya está disponible y anunciada de esta manera. Como novedades, el instalador gráfico usa e instala el Kernel 2.6.24 y sus imágenes ahora tienen un menú de arranque nuevo, además de soportar completamente particiones encriptadas. Otras novedades incluyen la transicióna Perl 5.10 y XULRunner, GCC 4.3 como el compilador por defecto en todas las plataformas y soporte para Python 2.5.

Ya se sabe que Lenny incluirá GNOME 2.22, pero todavía no hay noticias sobre qué pasará con KDE, cuya versión 4.1 se espera para dentro de muy poco.

viernes, 6 de junio de 2008

Agua en tu Escritorio


Es un juguete para tu X Windows, que permite tener interesantes animaciones de agua en tu escritorio.

Para debian testing

apt-get install xdesktopwaves.

Goosh, Google en modo consola

Goosh es una ingeniosa herramienta que en esencia es es un browser con una apariencia a un terminal shell que permite realizar busquedas rapidas en Google, incluido imágenes y noticias y Wikipedia y obtener la información en formato texto. Pensado en aquellos que sienten nostalgia por la linea de comandos y aseguran que trabajar en ese modo es mas rapido.
Se ha producido un error en este gadget.